• FreeBSD - note that sysinstall has offered binary upgrades since for ever --ceri

Notes from Jacob K (for FreeBSD):

When using the make method to upgrade the OS do the following: in /usr/share/examples/cvsup ""cp stable-supfile to /root

change *default release line to *default release=cvs tag=RELENG_5_3 (or OS version)

comment out *default compress

change *default host to cvs9.freebsd.org (or similar cvs host)

""run cvsup /root/stable-supfile

that updates /usr/src tree

if you have your own kernel config you have to specify the kernel name when you make buildkernel or else it'll automatically compile GENERIC

""make buildkernel KERNCONF=kernel-file-name ""make installkernel

otherwise just do this

""make -j4 buildworld ""make installworld ""make buildkernel ""make installkernel ""mergemaster

When using freebsd-update:

""/usr/local/sbin/freebsd-update fetch ""/usr/local/sbin/freebsd-update install

add it to cron to run every night as root:

""crontab -e

""45 4 * * * /usr/local/sbin/freebsd-update -v cron

this runs every night at 4:45am, installs any updates and emails root regardless of outcome